BETA

29th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/09/18 04:12 PM] with 'Partial Outage'

Issue has been resolved at [29/09/18 04:14 PM]