BETA

29th September 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [29/09/18 02:53 PM] with 'Major Outage'

Issue has been resolved at [29/09/18 02:55 PM]