BETA

1st May 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [01/05/17 04:18 PM] with 'Major Outage'

Issue has been resolved at [01/05/17 04:20 PM]