BETA

29th September 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [29/09/18 02:08 PM] with 'Partial Outage'

Issue has been resolved at [29/09/18 02:10 PM]