BETA

29th June 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [29/06/19 05:10 PM] with 'Major Outage'

Issue has been resolved at [29/06/19 05:13 PM]