BETA

1st May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/05/17 04:18 PM] with 'Partial Outage'

Issue has been resolved at [01/05/17 04:20 PM]