BETA

29th September 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [29/09/18 01:23 PM] with 'Partial Outage'

Issue has been resolved at [29/09/18 01:25 PM]