BETA

29th September 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [29/09/18 03:24 AM] with 'Partial Outage'

Issue has been resolved at [29/09/18 03:26 AM]