BETA

29th June 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [29/06/19 07:15 AM] with 'Major Outage'

Issue has been resolved at [29/06/19 07:17 AM]