BETA

28th September 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/09/18 01:05 PM] with 'Partial Outage'

Issue has been resolved at [28/09/18 01:10 PM]