BETA

28th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [28/09/18 01:02 PM] with 'Partial Outage'

Issue has been resolved at [28/09/18 01:03 PM]