BETA

28th September 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/09/18 01:00 PM] with 'Major Outage'

Issue has been resolved at [28/09/18 01:03 PM]