BETA

28th September 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [28/09/18 12:38 PM] with 'Partial Outage'

Issue has been resolved at [28/09/18 12:40 PM]