BETA

28th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [28/09/18 12:25 PM] with 'Major Outage'

Issue has been resolved at [28/09/18 12:26 PM]