BETA

1st May 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [01/05/17 10:56 AM] with 'Partial Outage'

Issue has been resolved at [01/05/17 10:57 AM]