BETA

27th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [27/09/18 07:43 PM] with 'Partial Outage'

Issue has been resolved at [27/09/18 07:44 PM]