BETA

27th September 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [27/09/18 06:37 PM] with 'Major Outage'

Issue has been resolved at [27/09/18 06:39 PM]