BETA

27th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/09/18 11:16 AM] with 'Major Outage'

Issue has been resolved at [27/09/18 11:18 AM]