BETA

26th September 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [26/09/18 08:20 PM] with 'Major Outage'

Issue has been resolved at [26/09/18 08:21 PM]