BETA

26th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [26/09/18 01:40 PM] with 'Partial Outage'

Issue has been resolved at [26/09/18 01:41 PM]