BETA Singapore cluster       Mumbai cluster

28th June 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [28/06/19 10:31 AM] with 'Partial Outage'

Issue has been resolved at [28/06/19 10:36 AM]