BETA

26th September 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [26/09/18 11:58 AM] with 'Partial Outage'

Issue has been resolved at [26/09/18 11:59 AM]