BETA Singapore cluster       Mumbai cluster

28th June 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [28/06/19 07:45 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/06/19 08:59 AM]