BETA

20th July 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [20/07/16 01:24 AM] with 'Partial Outage'

Issue has been resolved at [20/07/16 01:25 AM]