BETA

26th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [26/09/18 11:00 AM] with 'Major Outage'

Issue has been resolved at [26/09/18 11:15 AM]