BETA

26th September 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [26/09/18 10:17 AM] with 'Partial Outage'

Issue has been resolved at [26/09/18 10:18 AM]