BETA

28th June 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [28/06/19 04:45 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/06/19 04:49 AM]