BETA Singapore cluster       Mumbai cluster

28th June 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [28/06/19 03:22 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/06/19 03:39 AM]