BETA

28th June 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [28/06/19 03:16 AM] with 'Major Outage'

Issue has been resolved at [28/06/19 03:19 AM]