BETA

28th June 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [28/06/19 01:28 AM] with 'Partial Outage'

Issue has been resolved at [28/06/19 01:29 AM]