BETA

25th September 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [25/09/18 05:18 PM] with 'Major Outage'

Issue has been resolved at [25/09/18 05:20 PM]