BETA

28th April 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [28/04/17 11:00 AM] with 'Major Outage'

Issue has been resolved at [28/04/17 11:01 AM]