BETA

25th September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [25/09/18 08:48 AM] with 'Major Outage'

Issue has been resolved at [25/09/18 08:52 AM]