BETA

24th September 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [24/09/18 06:25 PM] with 'Partial Outage'

Issue has been resolved at [24/09/18 06:52 PM]