BETA

24th September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [24/09/18 06:21 PM] with 'Partial Outage'

Issue has been resolved at [24/09/18 06:26 PM]