BETA

24th September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [24/09/18 05:17 PM] with 'Partial Outage'

Issue has been resolved at [24/09/18 05:21 PM]