BETA

24th September 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [24/09/18 05:15 PM] with 'Partial Outage'

Issue has been resolved at [24/09/18 05:37 PM]