BETA

24th September 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [24/09/18 03:57 PM] with 'Partial Outage'

Issue has been resolved at [24/09/18 03:58 PM]