BETA

15th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [15/03/19 06:20 PM] with 'Partial Outage'

Issue has been resolved at [15/03/19 06:21 PM]