BETA

24th September 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/09/18 02:54 PM] with 'Partial Outage'

Issue has been resolved at [24/09/18 02:57 PM]