BETA

26th June 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [26/06/19 09:28 AM] with 'Major Outage'

Issue has been resolved at [26/06/19 09:39 AM]