BETA

28th April 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/04/17 10:28 AM] with 'Major Outage'

Issue has been resolved at [28/04/17 10:31 AM]