BETA

23rd September 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [23/09/18 11:29 AM] with 'Partial Outage'

Issue has been resolved at [23/09/18 11:32 AM]