BETA

23rd September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [23/09/18 10:09 AM] with 'Major Outage'

Issue has been resolved at [23/09/18 10:15 AM]