BETA

23rd September 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [23/09/18 08:52 AM] with 'Major Outage'

Issue has been resolved at [23/09/18 08:53 AM]