BETA

25th June 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [25/06/19 05:58 AM] with 'Partial Outage'

Issue has been resolved at [25/06/19 06:01 AM]