BETA

23rd September 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [23/09/18 01:53 AM] with 'Partial Outage'

Issue has been resolved at [23/09/18 01:55 AM]