BETA

22nd September 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [22/09/18 08:22 PM] with 'Major Outage'

Issue has been resolved at [22/09/18 08:25 PM]