BETA

22nd September 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [22/09/18 07:54 PM] with 'Partial Outage'

Issue has been resolved at [22/09/18 07:57 PM]