BETA

22nd September 2018

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [22/09/18 02:33 PM] with 'Major Outage'

Issue has been resolved at [22/09/18 02:34 PM]